Cisco Talos warns of Apple iOS and MacOS X.509 certificate flaw

Cisco Talos today warned of a flaw in the X.509 certificate validation feature of Apple macOS and iOS that could let an attacker remotely execute code and steal information.

X.509 security certificates are widely used and integral to many Internet protocols, including TLS/SSL, which is the basis for HTTPS, the secure web browsing protocol.

+More on Network World: 5 burning questions with new IETF Chair and Cisco Fellow Alissa Cooper+

“For most people, securely connecting to a website seems as simple as checking to make sure the little padlock in the address bar is present. However, in the background there are many different steps that are taken to ensure you are safely and securely connecting to the websites that claim they are who they are. This process includes certificate validation, or making sure that the servers that users are connecting to present “identification” showing they are legitimate. This helps to protect users from fraudulent servers that might otherwise steal sensitive information,” Talos wrote.

Talos wrote of the vulnerability: “When a client establishes a secure connection to a server, the server presents an x509 certificate which the client must validate. On Apple macOS, most client applications will use macOS’s certificate validation agent, at which point the malicious certificate will be parsed by the vulnerable code. This vulnerability can be triggered by, for example, visiting a HTTPS website with either Safari or Chrome, by connecting to a malicious mail server via Mail.app, or by simply importing the certificate by double clicking on it in finder. Possible scenarios where this could be exploited include users connecting to a website which serves a malicious certificate to the client, Mail.app connecting to a mail server that provides a malicious certificate, or opening a malicious certificate file to import into the keychain.”

+More on Network World: Cisco’s Jasper deal – one year, 18 million new IoT devices later, challenges remain+

Talos said it had confirmed macOS Sierra 10.12.3 and iOS 10.2.1 are vulnerable. Older versions of macOS and iOS are likely affected. However, Talos has not verified that they are. Talos said Apple has been told of the vulnerability and software updates have been released that address this issue for both macOS and iOS.

Check out these other hot stories:

FTC warns on “Can you hear me now” robocall: Hang up!

Cisco: IOS security update includes denial of service and code execution warnings

Can you imagine Mars with Saturn-like rings?

Cisco closes AppDynamics deal, increases software weight

Juniper extends data center interconnect options

Cisco issues critical warning after CIA WikiLeaks dump bares IOS security weakness

DARPA wants to cultivate the ultimate transistor of the future

DARPA plan would reinvent not-so-clever machine learning systems

Cisco security advisory dump finds 20 warnings, 2 critical

DARPA fortifies early warning system for power-grid cyber assault

Cisco’s Jasper deal – one year, 18 million new IoT devices later, challenges remain

Join the Network World communities on Facebook and LinkedIn to comment on topics that are top of mind.

Uncategorized

Leave a Reply